Fault with "RSP TourLite" rack light/reflector?

Discussion in 'Technical Chat' started by Adam Funk, Jan 25, 2011.

  1. Adam Funk

    Adam Funk Guest

    I ordered one of these not long after they were last discussed here,
    and was amazed by the battery life. So when I pushed the button this
    evening nothing happened, I assumed it was time to change the
    batteries. That didn't work, so I tried the old batteries in another
    light and they're still good. The light seems to have completely
    failed but I can't find any damage. Has anyone else had this problem?

    (Obviously I'll contact the retailer, which I have no reason to
    badmouth, about returning it. I'm just curious.)
     
    Adam Funk, Jan 25, 2011
    #1
    1. Advertisements

  2. Adam Funk

    Mike Causer Guest

    Every time I change the batteries in my LED headlights (~4 hours
    running time) I have to clean the contacts, both for the batteries in
    their carrier, and the carrier's contacts in the lights. Bit of a
    pain, but fingers crossed, they were both OK tonight, and might be
    tomorrow too.

    Cleaning varies from twiddle the battery around, to scrape contacts
    with sharp implement, to wash with alcohol contact cleaner.

    Might be worth a go.


    Mike
     
    Mike Causer, Jan 25, 2011
    #2
    1. Advertisements

  3. Adam Funk

    Adam Funk Guest

    Good ideas (they've worked for me on other things), but no such
    luck this time. Thanks for the tip, though.
     
    Adam Funk, Jan 26, 2011
    #3
  4. Adam Funk

    Paul Moss Guest

    A tiny smear of petroleum jelly (Vaseline) on the contacts will help tp
    prevent further corresion. Don't put too much.

    Paul.
     
    Paul Moss, Jan 29, 2011
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.